aboutsummaryrefslogtreecommitdiff
path: root/yadfa.asd (follow)
Commit message (Expand)AuthorAgeFilesLines
* another giant commit with a useless log messageGravatar Pouar2020-10-121-1/+1
* Make use of hooks from SerapeumGravatar Pouar2020-10-101-0/+1
* rework modulesGravatar Pouar2020-10-091-13/+15
* yet another mega commit that should probably be split up but ehGravatar Pouar2020-08-131-1/+4
* split libexec.lispGravatar Pouar2020-08-091-1/+5
* split bin.lispGravatar Pouar2020-08-091-1/+2
* make use of element types where they make senseGravatar Pouar2020-07-171-2/+2
* add new element typesGravatar Pouar2020-07-171-0/+3
* indentionGravatar Pouar2020-07-171-14/+14
* How the fuck did I leave that out?Gravatar Pouar2020-07-171-1/+1
* add new moveGravatar Pouar2020-05-281-14/+14
* remove data/prolog/moves.lispGravatar Pouar2020-04-281-1/+1
* decided to rewrite macro-level to use with-gensymsGravatar Pouar2020-04-281-2/+2
* use keywords instead of stringsGravatar Pouar2020-04-271-6/+7
* newer UIOP has :LOCAL-NICKNAMES in UIOP:DEFINE-PACKAGEGravatar Pouar2020-04-231-1/+1
* Use package local nicknamesGravatar Pouar2020-04-191-1/+1
* decided it was better not to generate these automaticallyGravatar Pouar2020-04-141-82/+22
* Let ASDF call make for the docsGravatar Pouar2020-04-141-3/+2
* add bibtex support for the to be written guideGravatar Pouar2020-04-131-2/+3
* We use this internally, might as well add itGravatar Pouar2020-04-091-1/+2
* workaround ECL bugGravatar Pouar2020-04-061-1/+1
* yadfa doesn't depend on trivial featuresGravatar Pouar2020-03-251-1/+1
* few changes to the testsGravatar Pouar2020-03-041-11/+1
* fix a few warningsGravatar Pouar2020-03-011-1/+3
* use fiveam-asdf from ASDF contribGravatar Pouar2020-02-281-2/+4
* add sanity testsGravatar Pouar2020-02-271-0/+9
* stop using package local nicknames for nowGravatar Pouar2020-02-261-1/+1
* forgot to include thisGravatar Pouar2020-02-251-1/+1
* maybe including these by default wasn't a good ideaGravatar Pouar2020-01-101-2/+1
* Don't include the extra presentation-to-command translatorsGravatar Pouar2019-12-141-1/+1
* Include ClouseauGravatar Pouar2019-12-131-1/+1
* commit what I got so farGravatar Pouar2019-12-061-1/+1
* use illogical pathnames for when logical pathnames aren't sufficientGravatar Pouar2019-11-231-1/+1
* another large commit that I should've probably split up firstGravatar Pouar2019-10-281-11/+21
* add a few new systems for moddersGravatar Pouar2019-10-011-1/+2
* make use of serapeum, also bug fixes and refactoringGravatar Pouar2019-09-191-1/+1
* fixesGravatar Pouar2019-08-281-1/+1
* make sure this is loaded firstGravatar Pouar2019-08-281-1/+1
* fix warningsGravatar Pouar2019-08-281-2/+2
* No more hacky Emacs abstractions for emulating CLIM in the SLIME/SlyGravatar Pouar2019-08-281-1/+1
* don't rely on the #+ reader macro and allow loading requiredGravatar Pouar2019-08-261-3/+6
* modify declt to allow texinfo commands in docstringsGravatar Pouar2019-08-241-6/+6
* allow the user to select any combination of the default clothes usingGravatar Pouar2019-08-221-1/+1
* file local variablesGravatar Pouar2019-08-041-1/+1
* less linesGravatar Pouar2019-07-101-117/+117
* switch to logical pathnames for mods,Gravatar Pouar2019-07-091-105/+105
* make sure the YADFA logical pathname host is defined beforeGravatar Pouar2019-07-081-2/+2
* use make-pathname instead of using pathnames directly, in caseGravatar Pouar2019-06-241-9/+36
* rename npc to enemy to make it easier to differentiate, alsoGravatar Pouar2019-05-201-5/+12
* more updatesGravatar Pouar2019-05-101-5/+13